ProjeQtOr free project management software - Installation with postgres - ProjeQtOr
 

Installation with postgres

More
24 Jun 2020 16:09 #1 by bengoshi
Hi:
I try to install prjeqtor. If I choose mysql the checkboxes of tool/configCheck.php will be shown. But I want to use postgres :)
If I choose postgres, there will be no error specious (click ok and nothing happens). The browser-inspector give me a 500 with the configCheck. url/tool/configCheck.php manual says:

PHP version is 7.3.14-1~deb10u1 : OK
Module PDO is available : OK
Module PDO for '' is not available - check your php configuration (php.ini)
[...]

I installed and activate pdo, so I have extension=pdo_pgsql and extension=pgsql in my php.ini.

My apache-error.log is confusing, because it sounds like a ssl-error. But in this case I should not see any page...:
[Wed Jun 24 13:50:01.789377 2020] [ssl:info] [pid 30392] [client 94.134.88.79:15473] AH01964: Connection to child 3 established (server projects.foo.org:443)
[Wed Jun 24 13:50:01.790325 2020] [ssl:debug] [pid 30392] ssl_engine_kernel.c(2319): [client 94.134.88.79:15473] AH02043: SSL virtual host for servername projeqtor.foo.org found
[Wed Jun 24 13:50:01.790350 2020] [core:debug] [pid 30392] protocol.c(2314): [client 94.134.88.79:15473] AH03155: select protocol from , choices=h2,http/1.1 for server projeqtor.foo.org
[Wed Jun 24 13:50:01.812869 2020] [ssl:debug] [pid 30392] ssl_engine_kernel.c(2235): [client 94.134.88.79:15473] AH02041: Protocol: TLSv1.3, Cipher: TLS_AES_128_GCM_SHA256 (128/128 bits)
[Wed Jun 24 13:50:01.813113 2020] [socache_shmcb:debug] [pid 30392] mod_socache_shmcb.c(495): AH00831: socache_shmcb_store (0xf4 -> subcache 20)
[Wed Jun 24 13:50:01.813143 2020] [socache_shmcb:debug] [pid 30392] mod_socache_shmcb.c(849): AH00847: insert happened at idx=0, data=(0:32)
[Wed Jun 24 13:50:01.813155 2020] [socache_shmcb:debug] [pid 30392] mod_socache_shmcb.c(854): AH00848: finished insert, subcache: idx_pos/idx_used=0/1, data_pos/data_used=0/212
[Wed Jun 24 13:50:01.813165 2020] [socache_shmcb:debug] [pid 30392] mod_socache_shmcb.c(516): AH00834: leaving socache_shmcb_store successfully
[Wed Jun 24 13:50:01.821515 2020] [ssl:debug] [pid 30392] ssl_engine_kernel.c(383): [client 94.134.88.79:15473] AH02034: Initial (No.1) HTTPS request received for child 3 (server projeqtor.foo.org:443)
[Wed Jun 24 13:50:01.821759 2020] [authz_core:debug] [pid 30392] mod_authz_core.c(820): [client 94.134.88.79:15473] AH01626: authorization result of Require all granted: granted
[Wed Jun 24 13:50:01.821781 2020] [authz_core:debug] [pid 30392] mod_authz_core.c(820): [client 94.134.88.79:15473] AH01626: authorization result of <RequireAny>: granted
[Wed Jun 24 13:50:01.823956 2020] [deflate:debug] [pid 30392] mod_deflate.c(856): [client 94.134.88.79:15473] AH01384: Zlib: Compressed 1207 to 341 : URL /tool/configCheck.php
[Wed Jun 24 13:50:06.829530 2020] [ssl:debug] [pid 30392] ssl_engine_io.c(1106): [client 94.134.88.79:15473] AH02001: Connection closed to child 3 with standard shutdown (server projeqtor.foo.org:443)

I have no ideas where I can keep on searching. Could anyone help me, please?

Please Log in or Create an account to join the conversation.

More
29 Jun 2020 12:14 #2 by babynus
Replied by babynus on topic Installation with postgres
It seem your parametering is wrong.
paramDbType semmes to be empty.

Other thing, if you installed with MySql, just changing parameters to connect to PostgreSql is a bad idea.
Some parameters won't be set.
Best is to delete flle rpojeqtor/tool/parametersLocation.php and run new configuration.

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.031 seconds