View ProjeQtOr On SourceForge.net
ProjeQtOr - Project Management Tool
Supportez nous sur Capterra
OIN - Open Invention Network
ProjeQtOr free project management software - [SOLVED] Error message after upgrade to PHP 8.1 - ProjeQtOr

Prochaines sessions de formation

Les prochaines formations et démonstrations sont ouvertes, inscrivez-vous rapidement !

 

Démonstration de ProjeQtOr

(gratuit, sur inscription)


Jeudi 7 juin (10h30-12h)

 
 

Planifiez avec ProjeQtOr

18 et 19 juin (9h - 12h30)

 
 

Administrez avec ProjeQtOr

25 et 26 juin (9h - 12h30)

 

 

 

[SOLVED] Error message after upgrade to PHP 8.1

More
16 Jui 2022 11:31 #1 by caccia
Hello,

I'm testing upgrade of my server to PHP 8.1, and after connection I get an error when displaying the left-side menu.

 

*
**** ERROR ***** [V9.5.5] on file '/projeqtor/view/menuNewGuiLeft.php' at line (677)
***** ERROR ***** [V9.5.5] cause = ucfirst(): Passing null to parameter #1 ($string) of type string is deprecated

Is there a solution for this ?
Attachments:

Please Connexion or Create an account to join the conversation.

More
16 Jui 2022 11:42 - 16 Jui 2022 11:43 #2 by babynus
There is an easy workaround : give a resource name to all users.

NB : fix will be included in V10.0

Babynus
Administrator of ProjeQtOr web site
Last edit: 16 Jui 2022 11:43 by babynus.

Please Connexion or Create an account to join the conversation.

More
16 Jui 2022 13:09 #3 by caccia
Unfortunately I'm still getting an error.
I updated to add some names everywhere, and now it seems both 'username' and full name' are ok :

 

But still the same error
Attachments:

Please Connexion or Create an account to join the conversation.

More
18 Jui 2022 09:12 #4 by babynus
Hi,

in file view/menuNewGuiLeft.php, replace line 677 from
$nameSubstr=ucfirst(pq_substr($nameSubstr,0,-4));
to 
$nameSubstr=($nameSubstr)?ucfirst(pq_substr($nameSubstr,0,-4)):'';

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
21 Jui 2022 09:26 #5 by caccia
Great to have a fix thanks :)
I'll stay on PHP 8.0 for now on our prod servers and upgrade after v10 to include the fix.

Thanks !

Please Connexion or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.060 seconds

Paramétrages de cookies

×

Cookies fonctionnels

Ce site utilise des cookies pour assurer son bon fonctionnement et ne peuvent pas être désactivés de nos systèmes. Nous ne les utilisons pas à des fins publicitaires. Si ces cookies sont bloqués, certaines parties du site ne pourront pas fonctionner.

Session

Veuillez vous connecter pour voir vos activités!

Autres cookies

Ce site web utilise un certain nombre de cookies pour gérer, par exemple, les sessions utilisateurs.