ProjeQtOr free project management software - New installation of V8.0.4 fails - ProjeQtOr

Prochaines sessions de formation à Paris et Montréal

Plusieurs sessions de formation sont prévues avant la fin de l'année

  • Le 21 Novembre à Paris (Porte d'Orléans)

Planifiez vos projets avec ProjeQtOr

  • Le 29 Novembre à Montréal (organisé par notre partenaire Québécois)

Chef de Projet sur ProjeQtOr

Pour de plus amples informations, ou pour vous inscrire, rendez-vous sur notre planning de formations.

 

New installation of V8.0.4 fails

More
13 Jui 2019 10:41 #13 by babynus
Is mbstring module enabled on your server ?

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
13 Jui 2019 10:51 #14 by briandlees
Attached is a screenshot of PHP modules loaded on active Apache server.
Attachments:

Please Connexion or Create an account to join the conversation.

More
13 Jui 2019 11:20 #15 by babynus
Hi,

I saw 2 miising modules that can have impact :
- calendar
- mcrypt

This last one (mcrypt) seems the best candidate for the issue.

NB : mysql_pdo is not installed, so I guess you configured with postgres...

Babynus
Administrator of ProjeQtOr web site
The following user(s) said Thank You: briandlees

Please Connexion or Create an account to join the conversation.

More
13 Jui 2019 11:51 #16 by briandlees
You are correct, I am using postgresql.
Adding calendar was easy, mcrypt not so. My distro (SUSE) has no official mcrypt extension as the module is deprecated in favour of OpenSSL. I managed to find a community version but have had to downgrade PHP from 7.2.x to 7.1.x in order to resolve the conflicts. I have got ProjeQtor installed and working now but I would request that you sort out the dependency on mcrypt.

I do not know how I can keep my PHP version current if you are using a deprecated module. Do you have any plans to remove this as it's already difficult to support and can only get worse?

However, thanks very much for your patience in helping me find the source of my issue.

Please Connexion or Create an account to join the conversation.

More
13 Jui 2019 14:04 #17 by babynus
I just checked a new server I have, runnng PHP 7.2 : mcrypt is not required.
But possibly calendar is...

Babynus
Administrator of ProjeQtOr web site
The following user(s) said Thank You: briandlees

Please Connexion or Create an account to join the conversation.

More
13 Jui 2019 16:52 #18 by briandlees
Thanks for that. I have re-upgraded to PHP 7.2 and without mcrypt it seems to work. Whether it's need for the first install I don't know. I have also found out that you can use PECL (PHP Extension Community Library) to provide the mcrypt functionality if required because the module is not included in PHP 7.2 at all.

Please Connexion or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.043 seconds