ProjeQtOr free project management software - [SOLVED] Error trying to add a Project - ProjeQtOr
 

[SOLVED] Error trying to add a Project

More
13 Mai 2019 11:53 #1 by pakkes
Hi,
I've installed Projeqtor 8.0.2 on a Apache 2.4 + Php 7.1.10 environment, on Windows 7 64bit. All ran as expected during installation and first setup.
However, I get an error while adding a new Project. The log tells that ...
2019-05-13 00:39:11.747 ***** ERROR ***** [V8.0.2] ERROR *****
2019-05-13 00:39:11.749 ***** ERROR ***** [V8.0.2] on file 'C:\Apache-2.4\htdocs\projeqtor\model\persistence\SqlElement.php' at line (2732)
2019-05-13 00:39:11.750 ***** ERROR ***** [V8.0.2] cause = Event::__construct() expects at least 4 parameters, 0 given
Any suggestion on how to avoid this error?
I first tried to use the 7.4.4 version of Projeqtor and getting the same exact error, so I moved to 8.0.2 ... same result.
Many thanks in advance for your help.
Regards

Please Connexion or Create an account to join the conversation.

More
13 Mai 2019 19:09 #2 by babynus
Hi,

Very stange, you get an error on some line that is called 1000 ties a day on active instance.
Possibly there is soething weird on your PHP Configuration, but I cannot guess what.

Try and remove E_STRICT mode on php.ini

error_reporting = E_ALL


Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
13 Mai 2019 19:42 #3 by pakkes
Hi.
Many thanks for the immediate reply!!!
I tried your suggestion .... I get same result.
Is there something I can do in order to give you more info about this?
Regards

Please Connexion or Create an account to join the conversation.

More
14 Mai 2019 09:55 #4 by babynus
Hi,

Did you restart PHP after change in php.ini ?

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
14 Mai 2019 10:00 #5 by pakkes
Hi,
yes, it shows 32767 with phpinfo(), it should be equal to E_ALL

Please Connexion or Create an account to join the conversation.

More
14 Mai 2019 10:19 #6 by babynus
Hi,

So we'll have to run some debug.
Can you pkease add 1 line in model/persistence/SqlElement before line 2732, this way :
  public static function getSingleSqlElementFromCriteria($class, $critArray, $withoutDepedentElements=false) {
    debugLog("getSingleSqlElementFromCriteria('$class')");
    $obj = new $class();
Then change logLevel to '3' in parameters.php.
Run projeqtor.
Post here trace found in log file.

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.032 seconds