ProjeQtOr free project management software - partial access to Teams & Pools; unable to attach new Resource to Organization - ProjeQtOr

Prochaines sessions de formation à Paris et Montréal

Plusieurs sessions de formation sont prévues avant la fin de l'année

  • Le 21 Novembre à Paris (Porte d'Orléans)

Planifiez vos projets avec ProjeQtOr

  • Le 29 Novembre à Montréal (organisé par notre partenaire Québécois)

Chef de Projet sur ProjeQtOr

Pour de plus amples informations, ou pour vous inscrire, rendez-vous sur notre planning de formations.

 

partial access to Teams & Pools; unable to attach new Resource to Organization

More
23 Sep 2019 13:24 - 23 Sep 2019 13:25 #1 by ggrelot
Since the 8.2.0 update I have the following strange behaviors on permissions :
- under an Administrator profile, I can view all Pools & Teams in the list, but I can't access any in the details view ("You don't have permission to access this element ..."
- we can't attach an Organization to a new Resource at the creation step, though we can do it by editing the Resource after its creation. This is obviously a problem when access to Resources by some profiles is to be restricted to "same Organization"...

Note: there also is a - probably unrelated - bug on access rights but I mention it just in case it could signal you some common cause from the database : in Access to non-project-dependent data > Legal Mentions I have an "8" for Administrator's access that I am unable to modify (update & read are proposed in the dropdown list but neither choice is taken into account when saving the page).

I attach the log of the day when the application was updated to 8.2.0.

File Attachment:

File Name: projeqtor_...0920.log
File Size:6 KB
*
(Today's log is 45Mo, i can't decently attach it but if you point me to something, I can search inside).
Attachments:
Last edit: 23 Sep 2019 13:25 by ggrelot.

Please Connexion or Create an account to join the conversation.

More
23 Sep 2019 21:55 #2 by babynus
Please try with V8.2.1, we fixed several layout issues

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
25 Sep 2019 16:22 #3 by ggrelot
1st issue : as admin, re-enabling the "Leave" module (which I had disabled when in 8.1.6) got the lacking 'Env parameters' screen available again. After updating to 8.2.1 as advised, I enabled a Resource as Employee then defined a valid module administrator, then disabled the module. The Env pram screens remain OK until now.

2nd issue : we still can't select an Organization at Resource creation. It seems like your demo instance undergoes the same issue (unless this behavior be a 'feature' I haven't yet seen the use of ;-)
As a consequence I must give access to the whole table of Resources to some people able then to attach them once created, which is quite cumbersome and error-prone.

3rd issue : In fact the "Generic functions" section in "Access to non-project-dépendent data" can't be updated and still displays "8" for Admin profile on Legal mention data. I suspect this new "legal mentions" thing to impair the whole section.

Please Connexion or Create an account to join the conversation.

More
26 Sep 2019 14:56 - 26 Sep 2019 14:59 #4 by babynus

1st issue : as admin, re-enabling the "Leave" module (which I had disabled when in 8.1.6) got the lacking 'Env parameters' screen available again. After updating to 8.2.1 as advised, I enabled a Resource as Employee then defined a valid module administrator, then disabled the module. The Env pram screens remain OK until now.

I did exactly what you described and cannot reproduce the issue.
Please be sure to disconnect / reconnect.
If issue is still there, please check for error in the log file and post any error here.

2nd issue : we still can't select an Organization at Resource creation. It seems like your demo instance undergoes the same issue (unless this behavior be a 'feature' I haven't yet seen the use of ;-)
As a consequence I must give access to the whole table of Resources to some people able then to attach them once created, which is quite cumbersome and error-prone.

This seems to be an issue. Ticket #4225 recorded.

3rd issue : In fact the "Generic functions" section in "Access to non-project-dépendent data" can't be updated and still displays "8" for Admin profile on Legal mention data. I suspect this new "legal mentions" thing to impair the whole section.

Issue confirmed.
Ticket #4226 recorded

Babynus
Administrator of ProjeQtOr web site
Last edit: 26 Sep 2019 14:59 by babynus.

Please Connexion or Create an account to join the conversation.

More
07 Oct 2019 19:54 - 09 Oct 2019 10:14 #5 by ggrelot
Thanks for the last 2 issues recorded.

For the first issue, the steps I related are the workaround, not the way to reproduce. I don't get the steps to reproduce : I just got the issue again, without any admin action, nor system update AFAIK, on Friday evening everything was OK and today I noticed that every "Env param" below "Resources" had disappeared, as have the associated lines in "Screen access" configuration.
Once again, I had to enable the HR module, enable my admin user account (which gets selected by default in Global params as HR habilitations admin) as an Employee resource, by which I recovered the missing lines in "Screen access" and was finally able to re-enable those Screens (Pools, Customers, etc.).

I don't see anything useful in today's logs though. In Friday's logs I don't find anything visibly related, but I see a (maybe unrelated) recurring error (cf. attached logfile extract).

File Attachment:

File Name: projeqtor_...rror.log
File Size:11 KB
Attachments:
Last edit: 09 Oct 2019 10:14 by ggrelot. Reason: attached instead of (non-displayed) inline code

Please Connexion or Create an account to join the conversation.

More
14 Oct 2019 11:29 #6 by babynus
Hi,

I'm not sure to completely understand the issue but it seems to be "Issue with menus on V8.2.1 when HR module is not enabled".
I recorded Ticket #4247 to analyse use case.

Error in logs has nothing to do with menu issue.
It is linked to Global View.
I guess it is an issue with PostgreSql DB.
Ticket #4248 recorded

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.034 seconds