ProjeQtOr free project management software - id 'ac5v4bnnvn6YU18C0PDN461300' is not numeric for class Client - ProjeQtOr

Formations en Amérique du Nord

Une formation est organisée par un de nos partenaires à Montréal.

Pour de plus amples informations, ou pour vous inscrire, rendez-vous sur notre planning de formations.

 

id 'ac5v4bnnvn6YU18C0PDN461300' is not numeric for class Client

More
11 Avr 2019 10:50 #1 by Segelohr
Hello everybody.

I evaluate Projeqtor for our company and installed V7.4.3 (224) on a Synology 918+
I accessed it with firefox 66.0.2 (64-Bit) and admin/admin

When I try to create any artefact (here for example a client) i loose connection
and the log entry is:

2019-04-11 10:07:49.113 ===== TRACE ===== NEW CONNECTED USER 'admin'
2019-04-11 10:08:11.149 ***** ERROR ***** [V7.4.3] HACK ================================================================
2019-04-11 10:08:11.149 ***** ERROR ***** [V7.4.3] Try to hack detected
2019-04-11 10:08:11.149 ***** ERROR ***** [V7.4.3] Source Code = SqlElement->_construct : id 'ac5v4bnnvn6YU18C0PDN461300' is not numeric for class Client
2019-04-11 10:08:11.149 ***** ERROR ***** [V7.4.3] QUERY_STRING =
2019-04-11 10:08:11.149 ***** ERROR ***** [V7.4.3] REMOTE_ADDR = 192.xxx.xxx.xx
2019-04-11 10:08:11.150 ***** ERROR ***** [V7.4.3] SCRIPT_FILENAME = /volume1/web/web_images/projeqtorV7.4.3/projeqtor/tool/getExtraRequiredFields.php
2019-04-11 10:08:11.150 ***** ERROR ***** [V7.4.3] REQUEST_URI = /tool/getExtraRequiredFields.php
2019-04-11 10:08:46.233 ===== TRACE ===== NEW CONNECTED USER 'admin'

I'd appreciate any help as i'm stuck at the moment

Best regards

Please Connexion or Create an account to join the conversation.

More
11 Avr 2019 15:55 #2 by babynus
Hi,

I don't know about synology, but it is possible that your system adds an unexpected attribute "id" to the requests with some token.
I think other users succeded to have ProjeQtOr work on synology.
Have a look at such threads in the forum.

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
11 Avr 2019 16:26 #3 by Segelohr
Unfortunately i didn't find a solution. Shouldn't 'id' be a int(12) which
'ac5v4bnnvn6YU18C0PDN461300' isn't.

I'll continue trying and write agan in case i find something

Please Connexion or Create an account to join the conversation.

More
11 Avr 2019 16:45 #4 by babynus
Of course ac5v4bnnvn6YU18C0PDN461300 is not an interger and so not a correct id.

In /tool/getExtraRequiredFields.php, just after include of projeqtor.php (in fist lines) add :
traceLog($_REQUEST);

Then play test case.
Check browser console, tab network, check the request you send and value of id sent.
Compare with value of id found in log file.
I guess they will be different...
This because your system adds something in the request that sets the mess with original request.

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
11 Avr 2019 20:58 #5 by Segelohr
Thanks, i'll try that.
By the way...I encountered a minute ago that it works with internet explorer

Please Connexion or Create an account to join the conversation.

More
11 Avr 2019 22:10 #6 by babynus
with which browser does it fail ?
Do you have some extension on this browser ?

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.089 seconds