ProjeQtOr free project management software - Update stuck on server - ProjeQtOr
 

Update stuck on server

More
13 Jui 2019 13:32 #1 by mvane
Update stuck on server was created by mvane
Hi there,

I've been using Projeqtor 7.0.9 from some time now and wanted to update to version 8.0.4.

I firstly copy the files of the 8.0.4 version, then I try to connect as an admin user, it lasts a very long time, and when I read the logs I can see that the update is correclty applied until the "Reformat WBS for PlanningElement" step but then it stops thus making the application unusable

This problem occurs only when I try the update on a distant server, it works very well on my computer with the same database as I have on the server.

Is it a known issue ? What could be causing it ?

Thanks for the help !

Please Connexion or Create an account to join the conversation.

More
15 Jui 2019 09:50 #2 by babynus
Replied by babynus on topic Update stuck on server
Are you sure it "stops" ?
Maybe it can be long if you have many activities.

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
19 Jui 2019 10:05 #3 by mvane
Replied by mvane on topic Update stuck on server
Hello,

I thought it was just long at first but I tried to let it run from june 13 until now and I still get the "update in progress" pop up if I try to connect to it and the logs are the same if we omit the connection attempts.

Also, the same update for a local database did not took more than 5 minutes

Please Connexion or Create an account to join the conversation.

More
21 Jui 2019 15:50 #4 by babynus
Replied by babynus on topic Update stuck on server
Please check for error message in projeqtor log file and in apache error log file.

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

More
21 Jui 2019 17:05 - 21 Jui 2019 17:06 #5 by mvane
Replied by mvane on topic Update stuck on server
Hello, I did check and I think an error stands out in OVH's error :

[error] [client} [host] AH10141: FastCGI: comm with server "/homez.112/domain/www/tool/loginCheck.php" aborted: idle timeout (160 sec), referer: www.domain.net/view/main.php?lostConnection=true

I tried to rerun an update on my computer to try with the max_execution_time set to 1 but I still am not able to reproduce the bug

Do you think this could be the issue ? Could it be linked to the "max_execution_time" configuration ? If it's that I have no luck because I can't update these parameters with my hostig solution.
Last edit: 21 Jui 2019 17:06 by mvane.

Please Connexion or Create an account to join the conversation.

More
21 Jui 2019 21:16 #6 by babynus
Replied by babynus on topic Update stuck on server
Yes, max_execution_time is the issue.
Shared hostef servers are ofter very limited and slow, so win't bring good performance.

But you can try and upgrade step by step, installing each major version : v1.0.0, then v2.0.0, and so one

Babynus
Administrator of ProjeQtOr web site

Please Connexion or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.029 seconds