ProjeQtOr free project management software - configuration d'envoi émail - Page 4 - ProjeQtOr
 

configuration d'envoi émail

More
25 Jul 2013 23:49 - 25 Jul 2013 23:58 #19 by timoumi
Dear babynus

sent to the users is ok, but the error is when I try to send the project information by email. :(
Thank y for help me.

Attachments:
Last edit: 25 Jul 2013 23:58 by timoumi.

Please Log in or Create an account to join the conversation.

More
26 Jul 2013 00:21 #20 by babynus
Please try and reply to questions one by one :

1) Check that the project manager has a correct email address.
Pay attention : project manager is the resource designed as manager on the project.

2) Try and change the "end of line format for mail" in the global parameters screen.
If your mail server uses postfix with version < 2.1 it will fix the issue.
It may also work in some other cases.

3) Can you try another mail receiver.
For instance, try "other" and enter an email you are sure must work.

=> 3 questions => you should provide 3 answers

You cannot get help if you don't give information. :evil:

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

More
26 Jul 2013 00:57 #21 by timoumi
:woohoo:
1- the project manager has a correct email address (my personel address).
2- I changed the "end of line format for mail" in the global parameters screen.
3- I try other mail on other domain(gmail, yahoo),
===> but always there is an ERROR when sending mail




LOG file:
2013-07-26 00:53:46 ===== TRACE ===== sendMailAnonymous
2013-07-26 00:53:47 ***** ERROR ***** ERROR *****
2013-07-26 00:53:47 ***** ERROR ***** on file 'C:\wamp\www\pro\tool\projector.php' at line (877)
2013-07-26 00:53:47 ***** ERROR ***** cause = mail() [<a href='function.mail'>function.mail</a>]: Failed to Receive
2013-07-26 00:53:47 ***** ERROR ***** Error sending mail
2013-07-26 00:53:47 ***** ERROR ***** SMTP Server : smtp.topnet.tn
2013-07-26 00:53:47 ***** ERROR ***** SMTP Port : 25
2013-07-26 00:53:47 ***** ERROR ***** Sendmail path :
2013-07-26 00:53:47 ***** ERROR ***** Mail stored in Database : #11
Attachments:

Please Log in or Create an account to join the conversation.

More
26 Jul 2013 19:44 #22 by babynus
The error message looks like you cannot reach the smtp server.
In may be because this server does not allow access on default port 25, or does not allow anonymous connections.
But what is very strange is that you say that you can send mails through user screen, as it uses the same code.

To understand, please modify /tool/projector.php this way :
change line 649 :
$resultMail=mail($to,$title,$message,$headers);
to :
debugLog("mail()");
debugLog("to=$to");
debugLog("title=$title");
debugLog("message=$message");
debugLog("headers=$headers");
$resultMail=mail($to,$title,$message,$headers);
debugLog("resultMail=$resultMail");

Then try to send 2 mails :
First from user (should work).
Second from project (should fail).
You should get some debug traced in the log file.
Please post them here (you may mask emails adresses for confidentiality).

Babynus
Administrator of ProjeQtOr web site
The following user(s) said Thank You: timoumi

Please Log in or Create an account to join the conversation.

More
27 Jul 2013 00:14 - 27 Jul 2013 00:17 #23 by timoumi
Exactly is what you tell me, the second essay does not work to send mail from project module.
:( I use the 3.4.0 version of proect'or ria
this is the log file:


2013-07-27 00:04:05 ===== TRACE ===== sendMailAnonymous
2013-07-27 00:05:16 ===== TRACE ===== sendMailAnonymous
2013-07-27 00:05:17 ***** ERROR ***** ERROR *****
2013-07-27 00:05:17 ***** ERROR ***** on file 'C:\wamp\www\pro\tool\projector.php' at line (883)
2013-07-27 00:05:17 ***** ERROR ***** cause = mail() [<a href='function.mail'>function.mail</a>]: SMTP server response: 451 See pobox.com/~djb/docs/smtplf.html .
2013-07-27 00:05:17 ***** ERROR ***** Error sending mail
2013-07-27 00:05:17 ***** ERROR ***** SMTP Server : smtp.topnet.tn
2013-07-27 00:05:17 ***** ERROR ***** SMTP Port : 25
2013-07-27 00:05:17 ***** ERROR ***** Sendmail path :
2013-07-27 00:05:17 ***** ERROR ***** Mail stored in Database : #14
Last edit: 27 Jul 2013 00:17 by timoumi.

Please Log in or Create an account to join the conversation.

More
27 Jul 2013 00:23 #24 by babynus
Hi,

The log is not as expected.
I expect some debug traces.
Maybe you should set logLevel to 3 in parameters.php
$logLevel='3';

Thne try again and post log result.

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.062 seconds