View ProjeQtOr On SourceForge.net
Support us on Capterra
ProjeQtOr free project management software - Upgrade from 4.4.2 to 4.5.x Issue - ProjeQtOr
 
 

Upgrade from 4.4.2 to 4.5.x Issue

More
04 Aug 2015 12:58 #1 by milien56
Hello,

I first tried to upgrade from 4.4.2 to the last stable release (4.5.7).
Following this upgrade even if everything looked going properly during upgrade, i wasn't able to create/modify a new task anymore.

The error message was "le champ 'mode de planification' est obligatoire". The sub-chapter of activity page, dealaing with "Workload stuff" is also not visible in the Activity creation/modification page. I guess there is an issue with planification or workloads.

Nore the planning gantt were accessible (empty white page).

I had a look on this topic: www.projeqtor.org/en/forum/10-feedbacks/...ing-to-4-5-3?start=6
which seems similar to my issue but i do not use sub-projects at all.


I finaly restored the v4.4.2 (everything went ok) and tried to upgrade to 4.5.0. I then get the same problem, that seems to confirm that issue is coming from planning calculation change from 4.5.X .....

I'm however unable to get out, do you have any idea where the issue could come from ?

Thanks
The topic has been locked.
More
04 Aug 2015 13:03 - 04 Aug 2015 14:07 #2 by milien56
Could it be that affectation rate rules betwwen project and sub-project also applies betwwen task and sub-tasks ?

Indeed, I usually affect ressources , affectation and workload only to sub-tasks while my sub-tasks are classified into main parent tasks (with non ressources affectation). Is this behaviour allowed by projeqtor v4.5.X ?

Here below is the log file content during last upgrade from 4.4.2 to 4.5.0:

2015-08-04 12:44:32 ===== TRACE ===== =====================================
2015-08-04 12:44:32 ===== TRACE =====
2015-08-04 12:44:32 ===== TRACE ===== DataBase actual Version = V4.4.2
2015-08-04 12:44:32 ===== TRACE ===== ProjeQtOr actual Version = V4.5.0
2015-08-04 12:44:32 ===== TRACE =====
2015-08-04 12:44:32 ===== TRACE ===== =====================================
2015-08-04 12:44:32 ===== TRACE =====
2015-08-04 12:44:32 ===== TRACE ===== VERSION V4.5.0
2015-08-04 12:44:32 ===== TRACE =====
2015-08-04 12:44:32 ===== TRACE ===== 1 lines updated into table "accessprofile".
2015-08-04 12:44:32 ===== TRACE ===== 1 lines updated into table "accessprofile".
2015-08-04 12:44:32 ===== TRACE ===== 1 lines inserted into table "dependable".
2015-08-04 12:44:32 ===== TRACE ===== 2 lines updated into table "planningmode".
2015-08-04 12:44:32 ===== TRACE ===== 1 lines inserted into table "accessscope".
2015-08-04 12:44:32 ===== TRACE ===== Table "audit" altered.
2015-08-04 12:44:32 ===== TRACE ===== 33 lines deleted from table "columnselector".
2015-08-04 12:44:32 ===== TRACE ===== 0 lines updated into table "assignment".
2015-08-04 12:44:33 ===== TRACE ===== Table "assignment" altered.
2015-08-04 12:44:33 ===== TRACE ===== Table "planningelement" altered.
2015-08-04 12:44:33 ===== TRACE =====
2015-08-04 12:44:33 ===== TRACE ===== DATABASE UPDATED
2015-08-04 12:44:33 ===== TRACE ===== WITH NO ERROR
2015-08-04 12:44:33 ===== TRACE =====
2015-08-04 12:44:33 ===== TRACE ===== =====================================
2015-08-04 12:44:33 ===== TRACE =====
2015-08-04 12:44:33 ===== TRACE ===== DATABASE UPDATE COMPLETED TO VERSION V4.5.0
2015-08-04 12:44:33 ===== TRACE =====
2015-08-04 12:44:33 ===== TRACE ===== =====================================
Last edit: 04 Aug 2015 14:07 by milien56.
The topic has been locked.
More
04 Aug 2015 14:31 #3 by babynus
Hi,

Here below is the log file content during last upgrade from 4.4.2 to 4.5.0:

First, be sure to upgrade to latest V4.5.7 (or at least V4.5.6, difference only concernes PostgreSql)

Then, after upgrade, be sure to clean browser cache.

I problem persists, check for errors in the log file and in the browser console.
I no errer, check network console, select lastest request and get response of that request (for instance, for blank Gantt chjart, get respont of request to jsonPlanning.php). Post response here.

Babynus
Administrator of ProjeQtOr web site
The topic has been locked.
More
04 Aug 2015 15:20 - 04 Aug 2015 15:37 #4 by milien56
Thanks for your prompt feedback.

I then upgraded back to v4.5.7, Browser cache has bean cleared, but same issue is encountered.
I checked plannedwork table and it's not empty.

I found this error in apache logs:

[Tue Aug 04 15:14:11 2015] [error] [client 192.168.10.43] PHP Fatal error: Call to undefined function mb_substr() in /var/www/html/projeqtor/model/GeneralWork.php on line 247, referer: https://192.168.50.220:543/projeqtor/view/main.php

=> i'll check for package php-mbstring...

I'm using PHP 5.3.3 (cli) (built: Nov 29 2012 04:12:23)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies



A Console error is appearing when accessing the gantt page is below:

exception in animation handler for: onEnd
SyntaxError: Identificateur, chaîne ou nombre attendu
{
[functions]: ,
__proto__: {
[functions]: ,
__proto__: { },
message: "",
name: "SyntaxError"
},
description: "Identificateur, chaîne ou nombre attendu",
message: "Identificateur, chaîne ou nombre attendu",
name: "SyntaxError",
number: -2146827260,
stack: "SyntaxError: Identificateur, chaîne ou nombre attendu
at drawGantt (https://192.168.50.220:543/projeqtor/view/js/projeqtor.js?version=V4.5.6.0113:1735:5)
at onEnd (https://192.168.50.220:543/projeqtor/view/js/projeqtor.js?version=V4.5.6.0113:702:18)
at _fire (https://192.168.50.220:543/projeqtor/external/dojo/dojo.js?version=V4.5.6.0113:15:21989)
at _cycle (https://192.168.50.220:543/projeqtor/external/dojo/dojo.js?version=V4.5.6.0113:15:24193)
at Anonymous function (https://192.168.50.220:543/projeqtor/external/dojo/dojo.js?version=V4.5.6.0113:15:89888)
at _501 (https://192.168.50.220:543/projeqtor/external/dojo/dojo.js?version=V4.5.6.0113:15:134318)
at Anonymous function (https://192.168.50.220:543/projeqtor/external/dojo/dojo.js?version=V4.5.6.0113:15:89888)"
}
Last edit: 04 Aug 2015 15:37 by milien56.
The topic has been locked.
More
04 Aug 2015 15:51 #5 by milien56
Ok my issue was coming form package php-mbstring that was not installed in my server.
Problem is now solved.

thanks
The topic has been locked.
More
04 Aug 2015 16:12 #6 by babynus
Hi,

it seems mbstring is not installed on your PHP server.
Try and install it.
Tell me if this fiexs the issue.

NB : on V5.1, it is planned to add controls on prerequisites to avoid this kind of errors.

Babynus
Administrator of ProjeQtOr web site
The topic has been locked.
Moderators: babynusprotion
Time to create page: 0.038 seconds

Cookies settings

×

Functional Cookies

Ce site utilise des cookies pour assurer son bon fonctionnement et ne peuvent pas être désactivés de nos systèmes. Nous ne les utilisons pas à des fins publicitaires. Si ces cookies sont bloqués, certaines parties du site ne pourront pas fonctionner.

Session

Please login to see yours activities!

Other cookies

Ce site web utilise un certain nombre de cookies pour gérer, par exemple, les sessions utilisateurs.