View ProjeQtOr On SourceForge.net
ProjeQtOr - Project Management Tool
Support us on Capterra
OIN - Open Invention Network
ProjeQtOr free project management software - Activity not displaying all three columns properly after attaching image - Page 2 - ProjeQtOr
 
 

Activity not displaying all three columns properly after attaching image

More
02 May 2020 14:15 #7 by babynus
But the log is from very old version.
Log file now contains version number on each line, this one does not.
Looking at file name it seems is it log from december 2016...
so not the last one (difficult to find source of error here)

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

More
03 May 2020 09:55 #8 by iconic
Please accept my apology, the reason why the log is very old is because I uploaded the wrong log. I have now uploaded the correct log of when the probably happened on the 29 April, 2020.

Please look at the correct log that I have uploaded relating to this problem and your assistance would be greatly appreciated of how to fix it.
Attachments:

Please Log in or Create an account to join the conversation.

More
04 May 2020 08:46 #9 by babynus
Hi,

The log file shows 2 errors, but none seem relative to your issue.

First can be fixed in /model/IndicatorValue.php, replacing line 312 from
$pe=get_class($obj).'PlanningElement';
to
$pe=(($obj)?get_class($obj):'').'PlanningElement';

Second can be fixed in /tool/projeqtor.php adding one line after line 5003, this way
function searchAllAttachmentMailable($objectClass,$idObj){
  if (!$objectClass or !$idObj) return array(array(),array());

Please try and apply these patches to see it it fixes your issue (I'm not very optimistic about this)

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

More
04 May 2020 09:09 #10 by iconic
I did as explained and the problem for this activity is the same.

Is there a way I can delete the images that were attached to the activity in the database and see if that fixes it. If so where in the database would I search for the images.

Please Log in or Create an account to join the conversation.

More
04 May 2020 09:13 #11 by babynus
you must search in table "attachment"
Before deleting, please post here content of the line (it may help solve the issue).

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

More
04 May 2020 09:56 #12 by iconic
Here is the content of the four images from the database. Can you spot anything unusual.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.046 seconds

Cookies settings

×

Functional Cookies

Ce site utilise des cookies pour assurer son bon fonctionnement et ne peuvent pas être désactivés de nos systèmes. Nous ne les utilisons pas à des fins publicitaires. Si ces cookies sont bloqués, certaines parties du site ne pourront pas fonctionner.

Session

Please login to see yours activities!

Other cookies

Ce site web utilise un certain nombre de cookies pour gérer, par exemple, les sessions utilisateurs.