ProjeQtOr free project management software - Template parameters and xml tags in description disappeared with upgrade to 5.1.5 - Page 2 - ProjeQtOr
 

Template parameters and xml tags in description disappeared with upgrade to 5.1.5

More
11 Jan 2017 09:02 #7 by ekolossov
Ok, this is very simple example:
Before upgrade description looks:
=================================
PROBLEM_DESCRIPTION:
Build: QAF-2.1.1-7343-qax (QAF 2.1.1. build #30)
Test environment: Windows 7 64-bit

If qacli view annotated source is executed on a header which itself includes a header file, annotated source is not generated for the included header file. Screenshot, project and logs attached.

METHOD_TO_REPRODUCE:
1. Open the attached project proj1
2. Clean then analyze the project:
qacli analyze -P . -fc
3. Generate the annotated source for test1.h
qacli view -P . -a -m HTML -- src/test1.h

ACTUAL RESULT:
The annotated source is produced only for test1.h

CLOSE_CRITERIA:
The annotated source is produced for test1.h and it's included file test2.h .

SAFETY_RELATED:
N/A
======================================
After upgrade it is looking this way:
======================================
PROBLEM_DESCRIPTION: Build: QAF-2.1.1-7343-qax (QAF 2.1.1. build #30) Test environment: Windows 7 64-bit If qacli view annotated source is executed on a header which itself includes a header file, annotated source is not generated for the included header file. Screenshot, project and logs attached. METHOD_TO_REPRODUCE: 1. Open the attached project proj1 2. Clean then analyze the project: qacli analyze -P . -fc 3. Generate the annotated source for test1.h qacli view -P . -a -m HTML -- src/test1.h ACTUAL RESULT: The annotated source is produced only for test1.h CLOSE_CRITERIA: The annotated source is produced for test1.h and it's included file test2.h . SAFETY_RELATED: N/A
================================================
Changing the editor to plain text:
===========================================
PROBLEM_DESCRIPTION: Build: QAF-2.1.1-7343-qax (QAF 2.1.1. build #30) Test environment: Windows 7 64-bit If qacli view annotated source is executed on a header which itself includes a header file, annotated source is not generated for the included header file. Screenshot, project and logs attached. METHOD_TO_REPRODUCE: 1. Open the attached project proj1 2. Clean then analyze the project: qacli analyze -P . -fc 3. Generate the annotated source for test1.h qacli view -P . -a -m HTML -- src/test1.h ACTUAL RESULT: The annotated source is produced only for test1.h CLOSE_CRITERIA: The annotated source is produced for test1.h and it's included file test2.h . SAFETY_RELATED: N/A
=============================================
Clean the cache:
=============================================
PROBLEM_DESCRIPTION: Build: QAF-2.1.1-7343-qax (QAF 2.1.1. build #30) Test environment: Windows 7 64-bit If qacli view annotated source is executed on a header which itself includes a header file, annotated source is not generated for the included header file. Screenshot, project and logs attached. METHOD_TO_REPRODUCE: 1. Open the attached project proj1 2. Clean then analyze the project: qacli analyze -P . -fc 3. Generate the annotated source for test1.h qacli view -P . -a -m HTML -- src/test1.h ACTUAL RESULT: The annotated source is produced only for test1.h CLOSE_CRITERIA: The annotated source is produced for test1.h and it's included file test2.h . SAFETY_RELATED: N/A
===========================================
As you can see changing editor has no effect

Please Log in or Create an account to join the conversation.

More
11 Jan 2017 22:11 #8 by babynus
issue recorded as Ticket #2496

Babynus
Administrator of ProjeQtOr web site

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 14:37 #9 by ekolossov
Hi,
Ticket #2496 marked as fixed but we still have the same behaviour in v.6.1.3.
As result we still cannot use the functionality we have paid for as we need to stay on the old version to prevent this problem.
Can you please fix this as soon as possible!

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 23:41 #10 by babynus
Hi Evgueni,

I have re-opend the ticket, but cannot reproduce.
I tested on description, on note, all is correctly displayed after insertion and also when trying to update the note.

Here is just an exemple of previous exemple you gave, as stored in V6.1.3.


Could you please give exemples of "non working" text.
Maybe some use case is not taken into account...
Some print screen may help solve the issue in all cases.

NB : note that is you saved data with incorrect formatting, we cannot revert to previous format (retreive deleted line breaks).
Fix works for new inputs and inputs not save in wrong format only.

Babynus
Administrator of ProjeQtOr web site
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Apr 2017 09:23 - 21 Apr 2017 10:04 #11 by babynus
Hi Evgueni,

I think I have the solution.
It seems issue occurs because your "long" fields (description, result) has size <= 4000 characters.
This idea is confirmed (i did not notice it before) by the fact that whatever you choose as editor, the editor displayed is plain text and not the selected editor.
If I remember well, it is a hint I gave you to preserve display of fields in plain text and never use formatted text.

Can you try and replace line 1801 in /view/objectDetail.php
from
echo formatAnyTextToPlainText($val);
to
if ($dataLength>4000) echo formatAnyTextToPlainText($val);
        else echo $val;
If you confirm this fixes the issue for you, fix will be included in next V6.2.2 patch, and prepared for V6.1.x if any required.

Babynus
Administrator of ProjeQtOr web site
Last edit: 21 Apr 2017 10:04 by babynus.

Please Log in or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.052 seconds