View ProjeQtOr On SourceForge.net
ProjeQtOr free project management software - Error on Install Auto plugin - Page 2 - ProjeQtOr
 

Error on Install Auto plugin

More
13 Aug 2019 11:46 #7 by Bena
Replied by Bena on topic Error on Install Auto plugin
I'm lost ...

This command should not work :

# php -r 'print file_get_contents(" projeqtor.org/admin/getInstallableVersio...urrentVersion=V8.1.3 ");'
{"V8.1.4":{"name":"V8.1.4","stable":"Y","lastStable":"Y","last":"Y","url":" projeqtor.org/version/projeqtorV8.1.4.zip","size":"49446492 "}}

But it works.

And there is no difference between my apache2 php.ini and the cli's one.

--
Bena

Please Log in or Create an account to join the conversation.

More
13 Aug 2019 14:29 - 13 Aug 2019 14:30 #8 by babynus
What is different is that in projector we use a context to shorten timeout

Can you please try and change line 168 in plugin/installAuto/installAutoZipList.php
from
return file_get_contents($fileName,false,$cxContext);
to
return file_get_contents($fileName,false,null);

Babynus
Administrator of ProjeQtOr web site
Last edit: 13 Aug 2019 14:30 by babynus.

Please Log in or Create an account to join the conversation.

More
14 Aug 2019 10:08 #9 by Bena
Replied by Bena on topic Error on Install Auto plugin
Nice, It works well with the modification.



Thanks :)

--
Bena
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Aug 2019 10:22 - 14 Aug 2019 10:22 #10 by babynus
Great !
We'll have an upgrade of the plugin to take this situation into account.

Babynus
Administrator of ProjeQtOr web site
Last edit: 14 Aug 2019 10:22 by babynus.

Please Log in or Create an account to join the conversation.

Moderators: babynusprotion
Time to create page: 0.042 seconds